f4i clutch rod - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-24-2007, 02:03 PM Thread Starter
 
Join Date: Mar 2007
Posts: 135
f4i clutch rod

Just tore my f4i left side cover off yesterday to see what the problem was w/ my clutch, since it went to the bar and didnt engage and the lever and cable was still intact. I was shocked to find out my clutch rod that goes in the side cover and engages the clutch was missing a chunk on the side of the factory slot.
Ive never seen that happen, just wanted to check here and see if anyone else has seen or heard of this.

Could have been ugly if it happen while i was practicing at my stunt spot working on coasters or any trick the clutch is involved in.
HiLi_Psyclez is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-24-2007, 02:34 PM
 
Join Date: Aug 2004
Posts: 2,394
So what happened to it? Did the chain hit it? My CBR is hydraulic, but still has a clutch rod.
No Worries is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome