Vehicle Rant - TwoWheelForum: Motorcycle and Sportbike forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 09-21-2007, 01:56 PM Thread Starter
 
1BadCBR's Avatar
 
Join Date: Dec 2005
Location: Georgia
Posts: 7,007
Send a message via Yahoo to 1BadCBR
Vehicle Rant

On Aug 23rd I took my 98 Isuzu Rodeo in for some work to be done (vehicle was shutting off while driving). Turns out, I needed to replace my EGR valve. No problem! I fork out the $552.10 to have the work completed, picked up the vehicle and everything seems to be working out just fine. Today (not quite 30 days later) the vehicle is doing the same thing.

WTF you ask....... I take it back to the same repair shop (Total Car Care Center) and now they are telling me that I need a fuel pump assembly which will cost with labor, $834.90. I bought freaking hit the roof.

I said WTF was the $552.10 for if it didn't fix the problem Then to top it off, the mechanic said that he still can't be sure it's the fuel pump until the vehicle stops running. Basically, he wants me to drive the vehicle until it breaks down......

I need a drink so that I can calm down!
1BadCBR is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 09-21-2007, 02:01 PM
TWF Champion
'07 Rally Veteran
 
NONE_too_SOFT's Avatar
 
Join Date: Nov 2006
Location: Akron OH
Posts: 5,720
you need a gun or a lawyer, yer gettin screwed.
NONE_too_SOFT is offline  
post #3 of 21 (permalink) Old 09-21-2007, 02:05 PM
TWF Board Of Directors
 
Join Date: Jun 2006
Posts: 10,074
Your first problem was paying $552 for an EGR valve. Those are easily replaced.

It only stops running while you are driving, not during idle? Does it start back up right away? If so, Id be looking for a loose connection in the electrical system.
Rider is offline  
post #4 of 21 (permalink) Old 09-21-2007, 02:09 PM Thread Starter
 
1BadCBR's Avatar
 
Join Date: Dec 2005
Location: Georgia
Posts: 7,007
Send a message via Yahoo to 1BadCBR
Quote:
Originally Posted by Rider View Post
Your first problem was paying $552 for an EGR valve. Those are easily replaced.

It only stops running while you are driving, not during idle? Does it start back up right away? If so, Id be looking for a loose connection in the electrical system.
EGR valve $302.95
E.F.I. cleaned $129.95
To put it on the fukin machine to see what was wrong with it $49.95
Shop supplies $5.00
Labor $40
Tax $24.25

Total 552.10

While I'm driving but it starts right back up.
1BadCBR is offline  
post #5 of 21 (permalink) Old 09-21-2007, 02:12 PM
Factory Racer
 
smileyman's Avatar
 
Join Date: May 2006
Location: Arkansas
Posts: 1,586
I call B.S.! Find another opinion, maybe 2. Fuel line pressure is regulated by the pump. Is yours in the tank? Could be a pick up problem but if it runs ok most of the time you shouldn't need a complete fuel pump.

"Industria, Virtus, et Fortitudo"
(means build it right, ride it hard, and never let up!)

Just Like lightning, only faster!
smileyman is offline  
post #6 of 21 (permalink) Old 09-21-2007, 02:15 PM Thread Starter
 
1BadCBR's Avatar
 
Join Date: Dec 2005
Location: Georgia
Posts: 7,007
Send a message via Yahoo to 1BadCBR
Quote:
Originally Posted by smileyman View Post
I call B.S.! Find another opinion, maybe 2. Fuel line pressure is regulated by the pump. Is yours in the tank? Could be a pick up problem but if it runs ok most of the time you shouldn't need a complete fuel pump.
I'm no mechanic but I believe it's in the tank.
1BadCBR is offline  
post #7 of 21 (permalink) Old 09-21-2007, 02:15 PM
TWF Board Of Directors
 
Join Date: Jun 2006
Posts: 10,074
Quote:
Originally Posted by 1BadCBR View Post
EGR valve $302.95
E.F.I. cleaned $129.95
To put it on the fukin machine to see what was wrong with it $49.95
Shop supplies $5.00
Labor $40
Tax $24.25

Total 552.10

While I'm driving but it starts right back up.
Does it act like it is running out of gas or does it just die suddenly? What year Rodeo? I think EGR valves go for uner $100. Do you get a check engine light?
Rider is offline  
post #8 of 21 (permalink) Old 09-21-2007, 02:29 PM Thread Starter
 
1BadCBR's Avatar
 
Join Date: Dec 2005
Location: Georgia
Posts: 7,007
Send a message via Yahoo to 1BadCBR
Quote:
Originally Posted by Rider View Post
Does it act like it is running out of gas or does it just die suddenly? What year Rodeo? I think EGR valves go for uner $100. Do you get a check engine light?
98 Rodeo
The check engine light, oil light, power and winter light, basically the whole dash flashes, comes on and then goes off. I'm going to call around to check some prices for a fuel pump and I'm also going to get a second opinion.
1BadCBR is offline  
post #9 of 21 (permalink) Old 09-21-2007, 02:29 PM
Factory Racer
 
smileyman's Avatar
 
Join Date: May 2006
Location: Arkansas
Posts: 1,586
I got into situation with one foreign make where the fuel pump would quit suddenly 'cause of a loose wire on the pump. Still had to pull the tank to diagnose it and fix it...Another one had a pin hole in the after the pickup where it would lose pressure and kick off. Can you hear the pump come on at key on?

"Industria, Virtus, et Fortitudo"
(means build it right, ride it hard, and never let up!)

Just Like lightning, only faster!
smileyman is offline  
post #10 of 21 (permalink) Old 09-21-2007, 02:30 PM Thread Starter
 
1BadCBR's Avatar
 
Join Date: Dec 2005
Location: Georgia
Posts: 7,007
Send a message via Yahoo to 1BadCBR
Quote:
Originally Posted by smileyman View Post
I got into situation with one foreign make where the fuel pump would quit suddenly 'cause of a loose wire on the pump. Still had to pull the tank to diagnose it and fix it...Another one had a pin hole in the after the pickup where it would lose pressure and kick off. Can you hear the pump come on at key on?
yea but then again I'm not really sure. My fuel gauge also reads as if I have no gas!
1BadCBR is offline  
post #11 of 21 (permalink) Old 09-21-2007, 02:35 PM
TWF Champion
 
Phenix_Rider's Avatar
 
Join Date: Nov 2006
Location: SouthWest, PA
Posts: 3,230
Send a message via AIM to Phenix_Rider
Quote:
Originally Posted by 1BadCBR View Post
yea but then again I'm not really sure. My fuel gauge also reads as if I have no gas!
Electrical problem... First try cleaning the battery terminals, and looking for burnt/ cracked insulation. Might be something is grounding when you hit a bump.

Check This: Hot New Artist Sailing up the charts!

'07 Ninja 650R Candy Plasma Blue
Got Gear?

Quote:
Originally Posted by NONE_too_SOFT View Post
All riders take risks- what you wear usually reflects your respect for the bike and general knowledge of riding.
Phenix_Rider is offline  
post #12 of 21 (permalink) Old 09-21-2007, 02:39 PM Thread Starter
 
1BadCBR's Avatar
 
Join Date: Dec 2005
Location: Georgia
Posts: 7,007
Send a message via Yahoo to 1BadCBR
Quote:
Originally Posted by Phenix_Rider View Post
Electrical problem... First try cleaning the battery terminals, and looking for burnt/ cracked insulation. Might be something is grounding when you hit a bump.
I'll try that this weekend....
1BadCBR is offline  
post #13 of 21 (permalink) Old 09-21-2007, 03:23 PM
First 1000 Member
April 2006 BOTM Winner!
'07 Rally Veteran
 
R1up0n1's Avatar
 
Join Date: Apr 2005
Location: Camp Hill / Hbg, PA
Posts: 9,790
Send a message via AIM to R1up0n1
Holy F'n sh*t man! #1 an EGR valve will NOT cause a vehicle to stop running... all that does is recycle the emissions...has nothing to do with causing the vehicle to stop running. Also you got ripped a new ass hole on that repair and they are quite simple to replace.


-My 2004 YZF-R1 - GYTR Exhaust, HID's, BMC Filter, PUIG DB, PCIII and more...
-2000 SV650 = Sold
-2003 R1 = Demolished, Sold
-2004 R1 = Lovin it!

http://www.myspace.com/r1upon1
R1up0n1 is offline  
post #14 of 21 (permalink) Old 09-21-2007, 03:27 PM
Factory Racer
 
smileyman's Avatar
 
Join Date: May 2006
Location: Arkansas
Posts: 1,586
If the EGR gets stuck or plugged then your gonna run terribly rich but no it won't kill the engine driving down the road.

"Industria, Virtus, et Fortitudo"
(means build it right, ride it hard, and never let up!)

Just Like lightning, only faster!
smileyman is offline  
post #15 of 21 (permalink) Old 09-21-2007, 06:23 PM
First 1000 Member
 
'73 H1 Triple's Avatar
 
Join Date: Jul 2004
Location: Zionsville,PA
Posts: 309
Quote:
Originally Posted by 1BadCBR View Post
yea but then again I'm not really sure. My fuel gauge also reads as if I have no gas!
Do you use a "Top Tier" gasoline? http://www.toptiergas.com/retailers.html

You may have a "gunk" build up on your fuel pump/ gas guage. I had to replace the fuel pump and two sending units in my '01 Suburban. Parts alone cost over $1200

Chevron makes a great fuel system cleaner. This is the one you want, accept no substitutes


Jeff
'73 H1 Triple is offline  
post #16 of 21 (permalink) Old 09-21-2007, 11:43 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
First check the fuel filter... but I don't think its that.

If it just died and you never said anything about other electrical problems at the same time... then I would say yeah fuel pump... EASY change... just drop the tank if you cant access it from under the back seat.

But with electrical... good luck.




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #17 of 21 (permalink) Old 09-22-2007, 07:08 AM
Privateer
 
Carolina's Avatar
 
Join Date: Jun 2006
Location: Augusta Georgia
Posts: 852
yeah mechanics are ****in crooks
Carolina is offline  
post #18 of 21 (permalink) Old 09-22-2007, 08:11 AM Thread Starter
 
1BadCBR's Avatar
 
Join Date: Dec 2005
Location: Georgia
Posts: 7,007
Send a message via Yahoo to 1BadCBR
maybe I'll just sell it.......I actually was going to save it for my daughter who starts college next year but now I'm starting to have second thougts.
1BadCBR is offline  
post #19 of 21 (permalink) Old 09-22-2007, 09:00 AM
Factory Racer
 
King Bob's Avatar
 
Join Date: Apr 2006
Location: New Port Richey FL
Posts: 2,142
Send a message via AIM to King Bob
Quote:
Originally Posted by 1BadCBR View Post
maybe I'll just sell it.......I actually was going to save it for my daughter who starts college next year but now I'm starting to have second thougts.
I wouldnt give my kids an Izuzu anything.

the EGR valve's only real purpose is to help the motor warm up faster in cold weather by rerouting hot exhaust gases from the exhaust into your intake to accelerate the warmup. it wont make it run rich, wont make the car die, it CAN cause a check engine light to come on.

you need to get away from that mechanic, if he's saying thats the problem, and wants to charge you for simply throwing parts at it instead of actually diagnosing the real illness and fixing it right, RUN.

your problem is more than likely a weak, loose or dirty connection on a wire somewhere. fix that issue, you'll be just fine.

life is but a way of killing time until you die. why care how you live, just have fun while you can.
King Bob is offline  
post #20 of 21 (permalink) Old 09-22-2007, 09:01 AM
Factory Racer
 
King Bob's Avatar
 
Join Date: Apr 2006
Location: New Port Richey FL
Posts: 2,142
Send a message via AIM to King Bob
Quote:
Originally Posted by smileyman View Post
If the EGR gets stuck or plugged then your gonna run terribly rich but no it won't kill the engine driving down the road.
EGR wont do that. O2 sensor will make it run rich. and I think(not certain) the mass airflow sensor too.

life is but a way of killing time until you die. why care how you live, just have fun while you can.
King Bob is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome