New need help please - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-17-2019, 08:57 PM Thread Starter
Learning To Post
 
Join Date: Jul 2019
Posts: 3
New need help please

Hey everyone new to the forum I recently purchased a 2006 Yamaha r6 and the guy told me he was running race gas in it he had it for a year only put 1000 miles on it my question is I filled it with non ethanol fuel and a few days later it had a rough idle almost like a normal engine with a upgraded cam has a slope to it and It has a full two brothers exhaust system on it is it running lean causing the rough idle like a lope because it doesnt have a power commander but at the same time it ran great with race fuel. I dont really want to seize the engine it's not running right at all thanks for your time let me know if you have any advise
Swiftr6 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome