95 ZX-6R Help.. - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-18-2008, 07:49 PM Thread Starter
 
Join Date: Aug 2008
Posts: 4
95 ZX-6R Help..

Hey guys, new here.

I just picked up a 1995 ZX-6R for 1,100.00 and it runs great but it sputters between 2 - 6,000 rpm and after 6,000 rpm it screams and takes off like crazy. I think I tracked it down to a weak fuel pump - Pulled the tank and the filter side of the fuel pump hose off and cranked on the bike until it started and it wasn't pumping and fuel & the lines were dry..( did all this after it left me stranded 4.5 miles from home one day ) so I called a few local places for a fuel pump and people want a crap load of money for a outdated piece of equipment. $140.00 +

I was wondering if anyone knew of the psi rating on the stock oem fuel pump and the lph/gpm/gph as I think I will just invest in a external universal fuel pump as long as it's in the right price bracket. Let me know and any future help is appreciated. =)


Nick.
95-ZX-6R is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-19-2008, 06:43 AM
 
Join Date: Jul 2005
Posts: 9,233
I don't know what the stock psi ratings are (I have a '95 ZX6R myself) but I DO know that bike is prone to some carb issues (which can cause problems similar to what you're experiencing), so before replacing that fuel pump (or at the same time), you might want to rebuild the carbs.
neebelung is offline  
post #3 of 3 (permalink) Old 08-20-2008, 12:39 AM Thread Starter
 
Join Date: Aug 2008
Posts: 4
Well I was getting a little pissed off today since I called like 7 differerent motorcycle sales / service places for Kawasaki's and nobody could tell me the PSI or LPH/GPM specs on the crummy little misubishi OEM fuel pump so I decided " well since its already broken lets take a look inside" so I pulled off that back little black cover and the inners it was covering/protecting just fell out..the spring , screws , the two metal lever clips - all of it so I did my best to line it all back up and put it back together - Simple..


Waiting until I get the chance to have some free time to pop it back in the bike and see if that fixed the issue with no fuel pumping out =)

Thanks for the advice btw. I also did the carb walkthrough clean out and found most of the jets were clogged that I couldn't even blow through them but now free and clear and I can see the light =)
95-ZX-6R is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome