f4i clutch installion - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 10-05-2006, 05:21 PM Thread Starter
First 1000 Member
 
rickmancc's Avatar
 
Join Date: Jun 2005
Location: HBG PA
Posts: 360
f4i clutch installion

Hello,

I have a simple question that should be easy. I was replacing the clutch on an 01 f4i today with the oem 03-06 rr clutch same oem part# not my first or second time replacing the clutch, but when I reinstalled the clutch cover, the clutch actuator seems like its not pulling the pressure plate, so I tok it all back apart and for *****s I re installed the old clutch and the same problem, is that correct? I am I missing something I have the factory manual and installed the plates in the correct order. but I should still notbe able to mover the actuator so easily with only the return spring giving me pressure. Let me know if any1 has ran across this issue.
Thanx 4 ur reply!
rickmancc is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 10-06-2006, 08:40 AM
 
Join Date: Jul 2005
Posts: 24,016




marko138 is offline  
post #3 of 12 (permalink) Old 10-09-2006, 08:04 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
BUMP!

I have no idea but its interesting...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 10-10-2006, 01:45 AM
Moderator
Lifetime Gold Supporting Member
'07 Rally Veteran
 
jeeps84's Avatar
 
Join Date: Oct 2004
Location: Western N.C. (The Great Smoky Mountains)
Posts: 20,168
Send a message via MSN to jeeps84
Check the basket and make sure it hasn't broken.

Submit your ride for the TWF Bike of the Month here


Currently ride 1987 GSXR 50, 1996 Ducati M900, 2005 GSXR 1000
jeeps84 is offline  
post #5 of 12 (permalink) Old 10-11-2006, 03:01 PM Thread Starter
First 1000 Member
 
rickmancc's Avatar
 
Join Date: Jun 2005
Location: HBG PA
Posts: 360
so far I found the plates to be a different heights so I ordered a barnett I will install it tonite, the basket is all ok
rickmancc is offline  
post #6 of 12 (permalink) Old 10-12-2006, 02:40 PM
Moderator
Lifetime Gold Supporting Member
'07 Rally Veteran
 
jeeps84's Avatar
 
Join Date: Oct 2004
Location: Western N.C. (The Great Smoky Mountains)
Posts: 20,168
Send a message via MSN to jeeps84

Submit your ride for the TWF Bike of the Month here


Currently ride 1987 GSXR 50, 1996 Ducati M900, 2005 GSXR 1000
jeeps84 is offline  
post #7 of 12 (permalink) Old 10-14-2006, 09:09 PM Thread Starter
First 1000 Member
 
rickmancc's Avatar
 
Join Date: Jun 2005
Location: HBG PA
Posts: 360
figured that the oem 600rr is not compaitable with the 01-03 f4i clutch the barnett clutch linked up ok
rickmancc is offline  
post #8 of 12 (permalink) Old 10-15-2006, 12:52 AM
Moderator
Lifetime Gold Supporting Member
'07 Rally Veteran
 
jeeps84's Avatar
 
Join Date: Oct 2004
Location: Western N.C. (The Great Smoky Mountains)
Posts: 20,168
Send a message via MSN to jeeps84
So the Barnett didn't work either?

Submit your ride for the TWF Bike of the Month here


Currently ride 1987 GSXR 50, 1996 Ducati M900, 2005 GSXR 1000
jeeps84 is offline  
post #9 of 12 (permalink) Old 10-16-2006, 08:37 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
NO I think he's saying the F4i replacement by barnett worked fine. Just that the 600RR stuff don't work on the f4i.




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #10 of 12 (permalink) Old 10-18-2006, 11:47 PM Thread Starter
First 1000 Member
 
rickmancc's Avatar
 
Join Date: Jun 2005
Location: HBG PA
Posts: 360
thanx 4 clearing that up gasman , that is what i meant
rickmancc is offline  
post #11 of 12 (permalink) Old 10-19-2006, 05:28 AM
 
Join Date: Jul 2005
Posts: 24,016




marko138 is offline  
post #12 of 12 (permalink) Old 10-20-2006, 01:14 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
No problem Rick.... glad to help..




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome