Gsxr 600 speedo out - TwoWheelForum: Motorcycle and Sportbike forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 (permalink) Old 02-01-2007, 12:07 PM Thread Starter
 
Join Date: Feb 2007
Posts: 8
hi everyone

i am new to the forum today and i need a bit of advise. i have got a gsxr 600 srad 1997, and my speedo has gone off. does anyone no how i can fix it? thanks
boomer is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 02-01-2007, 12:15 PM
TWF Board Of Directors
 
Join Date: Jun 2006
Posts: 10,074
Quote:
Originally Posted by boomer View Post
i am new to the forum today and i need a bit of advise. i have got a gsxr 600 srad 1997, and my speedo has gone off. does anyone no how i can fix it? thanks
but
Rider is offline  
post #3 of 23 (permalink) Old 02-01-2007, 12:35 PM Thread Starter
 
Join Date: Feb 2007
Posts: 8
thanks mate, am hopeing i can get it sorted before saturday cos bike is up for sale. always the way though.
boomer is offline  
Sponsored Links
Advertisement
 
post #4 of 23 (permalink) Old 02-01-2007, 01:26 PM Thread Starter
 
Join Date: Feb 2007
Posts: 8
Gsxr 600 speedo out

hello to everyone. i am a newbie with a problem. my gsxr 600 (analouge dial) speedo has gone off any ia how i can fix it. thanks
boomer is offline  
post #5 of 23 (permalink) Old 02-01-2007, 01:34 PM
 
Join Date: Jul 2006
Posts: 322
try posting up the suzuki section, probably get a better answer there.
tburda is offline  
post #6 of 23 (permalink) Old 02-01-2007, 01:46 PM
 
Join Date: Jan 2007
Posts: 24
Prob need a new speedo cable. Did you check it? oh yeah.. Welcome!
chumlysgrl is offline  
post #7 of 23 (permalink) Old 02-01-2007, 01:51 PM Thread Starter
 
Join Date: Feb 2007
Posts: 8
thanks mate.i have heard that it is electronic. i dont no if that is right, any ideas were it would be connected to if it was electroinc? i think it is a loose connection because it was intermitenly going off then on. thanks
boomer is offline  
post #8 of 23 (permalink) Old 02-01-2007, 01:54 PM
 
Join Date: Nov 2006
Posts: 2,181
SUP boomer..... man and

YZFR61ST is offline  
post #9 of 23 (permalink) Old 02-01-2007, 02:03 PM Thread Starter
 
Join Date: Feb 2007
Posts: 8
thanks for the welcome, what does SUP mean? im lost when it comes to the forums.
boomer is offline  
post #10 of 23 (permalink) Old 02-01-2007, 02:06 PM
TWF Board Of Directors
 
Join Date: Jun 2006
Posts: 10,074
Quote:
Originally Posted by boomer View Post
thanks for the welcome, what does SUP mean? im lost when it comes to the forums.
Its short for "Whats Up?"
Rider is offline  
post #11 of 23 (permalink) Old 02-01-2007, 02:13 PM Thread Starter
 
Join Date: Feb 2007
Posts: 8
oh yeah. cant believe i didnt realise that.
boomer is offline  
post #12 of 23 (permalink) Old 02-01-2007, 02:15 PM
 
Join Date: Nov 2006
Posts: 2,181
Quote:
Originally Posted by boomer View Post
oh yeah. cant believe i didnt realise that.
....... ......
YZFR61ST is offline  
post #13 of 23 (permalink) Old 02-01-2007, 04:58 PM
 
saverok's Avatar
 
Join Date: Nov 2006
Location: nashville,tn
Posts: 3,906
Quote:
Originally Posted by boomer View Post
hello to everyone. i am a newbie with a problem. my gsxr 600 (analouge dial) speedo has gone off any ia how i can fix it. thanks
man that sucks. first check your cables and make sure nothing has shorted out or disconnected....then well I don't know. get your self a repair manual. you can download it in the tech section on line.

Quote:
They call me Mr. Saverok
Silence is golden: Duct tape is silver.
saverok is offline  
post #14 of 23 (permalink) Old 02-01-2007, 07:56 PM
 
Join Date: Jan 2006
Posts: 2,017
gone off? where?
do you mean that it doesn't move or it's pegged even when not moving?

those are gear driven. i don't remember the years but check the cables, it may have unscrewed off the speedo.

-a|ex
Back _Marker is offline  
post #15 of 23 (permalink) Old 02-01-2007, 08:38 PM
 
Join Date: Apr 2006
Posts: 2,142
OR the cable may have broken too, and be in need of replacment.
King Bob is offline  
post #16 of 23 (permalink) Old 02-01-2007, 09:42 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Quote:
Originally Posted by tburda View Post
try posting up the suzuki section, probably get a better answer there.
Moved it to the tech section with a re-direct in the suzuki section..

If its a cable I'd check that for sure... un hook it from each end and see if you can spin it.

If its electric... check for fuses...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #17 of 23 (permalink) Old 02-02-2007, 12:56 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Also MERGED your 2 threads about the same thing...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #18 of 23 (permalink) Old 02-02-2007, 04:44 PM
 
Join Date: Nov 2004
Posts: 5,314
1997 srad... where is the speedo driven from on those bikes?
JK_DILLA is offline  
post #19 of 23 (permalink) Old 02-02-2007, 06:43 PM
 
Join Date: Jul 2005
Posts: 24,016
Quote:
Originally Posted by JK_DILLA View Post
1997 srad... where is the speedo driven from on those bikes?
I dont know when Zook went to the countershaft....


Check and see it your cable goes to the front wheel. If you've removed the wheel anytime recently you may have broken off the little piece that fits into the wheel. They break easy.



marko138 is offline  
post #20 of 23 (permalink) Old 02-02-2007, 07:16 PM
 
Join Date: May 2005
Posts: 2,248
Quote:
Originally Posted by boomer View Post
i am new to the forum today and i need a bit of advise. i have got a gsxr 600 srad 1997, and my speedo has gone off. does anyone no how i can fix it? thanks

Found it Gsxr speedo
Attached Thumbnails
Click image for larger version

Name:	Gsxr speedo.jpg
Views:	104
Size:	44.0 KB
ID:	6755  
ne1469 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome