03 F4i help-start up issues - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-02-2007, 11:11 PM Thread Starter
 
Join Date: Feb 2006
Posts: 8
03 F4i help-start up issues

Question for the F4i owners or mechanics... I tried to start my bike ever since this warm weather started but it wont start I have its turning over but is not kicking in..... my battery is fully charged engine kill switch is set to on, I hear the fuel pump hiss when i turn it on it just wont start...

I took out one spark plug and it didnt look to bad, I didnt notice or smell any fuel on it....

I am thining of changing the fuel filter but it looks like a lot of work and I wanna know if this is whats causing it for sure....

or should i just first try replacing all the plugs?

before I put it away all I did was add stabalizer and change the oil... the bike has 25,000km on it the plugs were changed at 17,000.

I know I sound like a rookie and all with the mechanics of this bike but any help or suggestions would be appreciated!

Thanks
kaboom78 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-02-2007, 11:14 PM
 
Join Date: Jul 2005
Posts: 24,016
Throw new plugs in it. I bet she fires.



marko138 is offline  
post #3 of 5 (permalink) Old 04-03-2007, 11:41 AM
 
Join Date: Feb 2007
Posts: 110
Quote:
Originally Posted by marko138 View Post
Throw new plugs in it. I bet she fires.
Like you said also sounds like it's not getting any fuel. I'd not only check the fuel filter but check the fuel pump to make sure it's actually pumping fuel out and not just "hissing". Check your fuel lines too for any cracks.
rockinthef4i is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-04-2007, 06:48 PM
 
Join Date: Mar 2007
Posts: 135
from what i read sounds like your bike ran when you stored it.. if so try new plugs liek said above and some fresh gas. If the pump is priming then all the electrical should be good
HiLi_Psyclez is offline  
post #5 of 5 (permalink) Old 04-04-2007, 07:18 PM
 
Join Date: Sep 2006
Posts: 114
!

If your bike was in storage your main problem will be clogged injectors! as for cleaning them i've never done it myself but im sure someone here will have the knowledge!

As for changing the fuel filter? there isint just one filter...but three filters! there's two filters inside the actual fuel pump housing and the third inside the injector! the main one to be cleaning/changing will be either one or both inside the pump housing
KillerR33d is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome