Gas tank Leaking Fuel? - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-14-2007, 02:47 AM Thread Starter
Knee Dragger
 
Join Date: Mar 2007
Location: Northern Kentucky
Posts: 343
Gas tank Leaking Fuel?

I need some help as I'm scratching my head on this one. I finally rebuilt my engine after 2 years of sitting torn apart. The gas tank and fuel pump were fine for 2 years when I emptied the old fuel and put new fuel in, it started flowing from the fuel pump. No power was connected so it shouldn't have been doing anything and I'm confused because it had fuel in it before and never leaked.

Any ideas?

Btw it's a 95 YZF600R
oldman2007 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-14-2007, 08:30 AM
 
Join Date: Mar 2007
Posts: 135
not sure how the setup is on those bikes. I know theyre not injected, i thought they were gravity fed like the f2's but if you have a pump guess not...

Is the petcock in the off position? if your petcock is on on or reserve theres your problem, easy mistake. might have been on and not had enough gas in before to leak out ???
HiLi_Psyclez is offline  
post #3 of 7 (permalink) Old 04-14-2007, 11:56 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Does it have a petcock?

If so it most likely isn't FI and therefor it shouldn't have a pump in it?

Another way to check...

Is there a compartment at the bottom rear of the tank? A plate that unbolts for access to a fuel pump? If not... no pump!




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 04-16-2007, 08:07 AM Thread Starter
Knee Dragger
 
Join Date: Mar 2007
Location: Northern Kentucky
Posts: 343
It does not have a petcock. It does have a fuel pump and it isn't supposed to pump (release) any fuel unless there is power to it. The tank sat for 2 years on the floor of my garage w/o leaking a drop. When I replaced the gas to start it after rebuilding the engine is when it started leaking.

People have said that as long as the floats in the carbs are working it shouldn't matter if it leaks the carbs will regulate it... It does bother me a little as to why it's doing it but I priced out a new fuel pump etc and it's over 500 bucks so I'm inclined to let it go.
oldman2007 is offline  
post #5 of 7 (permalink) Old 04-16-2007, 08:11 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Are you sure there is a fuel pump?

Carbs don't use fuel pumps on bikes...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #6 of 7 (permalink) Old 04-16-2007, 08:47 AM Thread Starter
Knee Dragger
 
Join Date: Mar 2007
Location: Northern Kentucky
Posts: 343
yes I'm positive there is a fuel pump.

http://houseofmotorcycles.bikebandit...e~YZF600RG.asp
oldman2007 is offline  
post #7 of 7 (permalink) Old 04-16-2007, 10:26 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Well looky there... didn't know they ran a pump on those older bikes... who would have tunk... learn somin new...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome