o2 eleminator - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-01-2007, 06:44 PM Thread Starter
 
Join Date: Jun 2007
Posts: 44
o2 eleminator

I have an 06 f4i with 4300 miles. I installed a slip on with out an oxygen sensor hole so I used an o2 eleminator from dynojet. everything has been fine for a while, but about 1000 miles ago I noticed a ticking sound at about 4500 to 6000 rpm, I think it is the cam chian tensioner, people say they go bad often, and it seems to be a little sluggish bringing on the power. Any thoughts on the c.c.t. or how important the o2 working correctly is?
haasman is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-03-2007, 02:35 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Not sure about the o2. But if you have the eliminator than I would think you're fine.

Yes the auto cct on those motors always goes out. Do yourself a favor... install a manual CCT. That way you never have to replace it again!




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #3 of 5 (permalink) Old 07-03-2007, 11:27 AM
Banned
 
PlayfulGod's Avatar
 
Join Date: May 2007
Location: Dalton, Georgia
Posts: 9,569
Send a message via AIM to PlayfulGod Send a message via MSN to PlayfulGod
exactly what does this sound like? Mines makes a noise but it dont sound like anything I've heard b4 and it hasnt affected performance.
PlayfulGod is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 07-06-2007, 05:39 PM Thread Starter
 
Join Date: Jun 2007
Posts: 44
sorry I been away a while. It sounds like a rapid tapping sound. If it was a car I would say the lifters where tapping.
haasman is offline  
post #5 of 5 (permalink) Old 07-08-2007, 03:11 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Quote:
Originally Posted by haasman View Post
sorry I been away a while. It sounds like a rapid tapping sound. If it was a car I would say the lifters where tapping.
THat is most likely your CCT




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome