Torque wrench arrrg - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-10-2009, 07:27 PM Thread Starter
 
Join Date: Jun 2009
Posts: 0
Torque wrench arrrg

I've never used a torque wrench before. I had 2 in my garage that had been sitting there for about 15 years. Both of them ratchet just fine and the torque setting handle turns just fine too, but no matter what setting I put it on the end of it never slips. So I went out and bought a new $50 wrench and the same thing happens. Can't get it to slip no matter what the torque is set to. I highly doubt all 3 wrenches are broken, it's something I'm doing wrong. Is there something special you have to do to get the end to slip or just set torque and turn?
skyhawk04kilo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-18-2009, 04:54 PM
 
Join Date: Sep 2007
Posts: 48
they really don't slip, they just click, unless its the old kind that has a gauge on the bottom of the handle.
TXEMT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome