Weird electrical issue with bike - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-01-2011, 07:30 AM Thread Starter
Learning To Post
 
Join Date: Jan 2011
Posts: 1
Weird electrical issue with bike

2005 Suzuki GZ-250

It seems as though my battery is dead but i'm not so sure, because the bike is acting erratically.

I go out yesterday to start, and all i get is a click. Just one click, it won't do anything at all after that. I go out a little while later to try it, but nothing. I turn the key around in the ignition, and then the lights and turn signal come on. So i try to start again and i get the click and the lights go out immediately (they don't fade out).

The headlight came on fully so i'm pretty sure the battery is in good shape, but I don't have anything to check it with.

Obviously it has something to do with the electrical stuff, but I know very little about the nuts and bolts of motorcycles, or anything else for that matter.

Any ideas.
zulubanshee is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-17-2011, 09:41 AM
Newbie
 
Join Date: Sep 2008
Posts: 9
That definitely sounds like the battery! A new one can be found here:

http://www.bohannonbattery.com/html/motbat/7lbs.html
Jbo24 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome