2001 Suzuki sv650 electrical problem - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-20-2012, 05:50 PM Thread Starter
Learning To Post
 
Join Date: Oct 2012
Posts: 1
2001 Suzuki sv650 electrical problem

Hello everyone,

I own a 2001 Suzuki sv650 (naked). After being under the rain, the motorcycle won't start. I left it to dry out but even after a week it won't start either. When I turn ignition switch, none of the lights come one, not even gauges. Basically, turning ignition does nothing. I checked the battery (recharged it) and same deal, nothing is happening. One day I turned the bike one and it worked for a second, as soon as I started to warm it up, it died on me again. Since than, it has been already few weeks, the motorcycle won't start. What should I do? I checked air filter, it's dry.... I looked at spark plugs, they look normal.... Idk what else should I do.
dushakov is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome