94 suzuki RF600 carb prob? - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-22-2005, 02:00 AM Thread Starter
 
Join Date: Sep 2005
Posts: 2
94 suzuki RF600 carb prob?

alrite so i got a 94 suzuki RF600. one day its running great and the next it just runs worse every 5 mins till it wont start. i got spark so i guess im not gettin fuel. now i read up and i herd they had problems. does this ring a bell to anyone? what should i do? there them apart and clean them? help me out i cant go another day with out my bike!
twelve oclock is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-22-2005, 09:04 AM
 
Join Date: Jul 2004
Posts: 955
might just have some crap in the carbs, u need to either clean them yourself or have it done...only thing i can think of....

that or you have some crap in the tank itself and its clogging up the fuel filter.....

Last edited by GsxrJack; 09-22-2005 at 10:01 AM.
GsxrJack is offline  
post #3 of 5 (permalink) Old 09-22-2005, 11:15 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
12!!!




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 09-22-2005, 11:18 AM
 
Join Date: Oct 2004
Posts: 6,147
Quote:
Originally Posted by GsxrJack
might just have some crap in the carbs, u need to either clean them yourself or have it done...only thing i can think of....

that or you have some crap in the tank itself and its clogging up the fuel filter.....

...Start at the gas tank and work your way out the exhaust...you might find a clog somewhere.
bumblebee is offline  
post #5 of 5 (permalink) Old 09-26-2005, 07:44 AM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
He got it figured out...

See this update thread.






-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome