95 ZX9R Water pump problems :( - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-19-2006, 05:14 PM Thread Starter
 
Join Date: Aug 2005
Posts: 17
95 ZX9R Water pump problems :(

The title explains itself.... My water pump isnt working and my engine is overheating....Theres no rad fluid going anywhere.... How do I fix it?
Aesop Ninja is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-19-2006, 10:15 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Get a service manual and a new water pump from the dealer! Or just take it into the dealer in a pick up!




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #3 of 9 (permalink) Old 01-19-2006, 10:36 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Quote from the other thread! A place to get manuals...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 01-20-2006, 01:50 AM
 
Join Date: Feb 2005
Posts: 17,886
Could also be your thermosatat. I'd replace both at the same time. It can't be that much.
DLIT is offline  
post #5 of 9 (permalink) Old 01-20-2006, 07:46 AM
 
Join Date: Oct 2004
Posts: 6,147
I'd do thermostat first...when water pumps go out...there is usually evidence of water leaking around the seals
bumblebee is offline  
post #6 of 9 (permalink) Old 01-20-2006, 04:57 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Quote:
Originally Posted by bumblebee
I'd do thermostat first...when water pumps go out...there is usually evidence of water leaking around the seals





-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #7 of 9 (permalink) Old 01-20-2006, 09:25 PM
First 1000 Member
 
Join Date: Jul 2004
Location: Louisville, KY
Posts: 408
I guess the first question is...how did you determine the water pump is not circulating coolant?

Larry

Rarely is the question stupid, but sometimes the answer is you need to run everything you read online through your own personal BS meter to determine if it makes sense to you.
larryg is offline  
post #8 of 9 (permalink) Old 01-21-2006, 01:24 AM
Moderator
Lifetime Gold Supporting Member
'07 Rally Veteran
 
jeeps84's Avatar
 
Join Date: Oct 2004
Location: Western N.C. (The Great Smoky Mountains)
Posts: 20,168
Send a message via MSN to jeeps84
Quote:
Originally Posted by larryg
I guess the first question is...how did you determine the water pump is not circulating coolant?

Larry
check the thermostat first.

Submit your ride for the TWF Bike of the Month here


Currently ride 1987 GSXR 50, 1996 Ducati M900, 2005 GSXR 1000
jeeps84 is offline  
post #9 of 9 (permalink) Old 01-24-2006, 11:12 AM
 
Join Date: Jan 2006
Posts: 2,017
Quote:
Originally Posted by Aesop Ninja
The title explains itself.... My water pump isnt working and my engine is overheating....Theres no rad fluid going anywhere.... How do I fix it?
Not enough info...

Fan not working? Low coolant? ever changed the coolant? pressure cap faulty? water pumps don't just quit working. there is usually something that damages them. what's the temp and when does it overheat?

-a|ex
Back _Marker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome