Suzuki bike troubles - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 12-06-2005, 07:39 PM Thread Starter
Ken
 
Join Date: Dec 2005
Posts: 3
Suzuki bike troubles

My name is Ken Vallis and I live in Brownsdale, Newfoundland. I would like to let all the people who are looking at this site know about the kind of service they may expect to receive if they, like me, purchase a Suzuki product. It all started three months after I purchased my Suzuki LT-F400FK3 Eiger ATV when the clutch failed to work. After three weeks at the shop waiting on the clutch,( which was on back-order ) I picked up the quad, only to get the use of it for fifteen minutes before the engine seized and I had to push the quad home. A little over a year ago I had a letter printed in a provincial paper about all the trouble I was having .At that time the quad was in the shop a total of three months waiting on back-order parts for the engine. Shortly after the letter was printed all the parts arrived. I was in constant contact with Suzuki Canada and they assured me that after the repairs were complete that I would have no more worries concerning the engine. They were wrong, since then I have put over 2600 kmís on my car bringing the quad to and from the shop for problems with the engine as well as other things, there is still only 1840 kmís on the quad. It seem that almost every time I go for a ride I encounter problems. The last time I had to push the quad almost three kmís out off the woods after the engine blew the oil out to the point where more damage would occur if I ran it. That was three months ago and again the quad remained at the shop waiting on you guessed it back order parts. I have tried to contact Suzuki Canada through several phone calls and E-mail with no response. I know that I now have had the quad for two years and the warranty has expired but the initial problem with the engine still had not been fully repaired. All I wanted from the beginning was for Suzuki to replace the engine with a new one ( Which they say they donít have ). With only 500 kmís on the quad at the time I felt that was a reasonable request but it seems that the people at Suzuki would rather have their customers go through the agony that I have had and still am having. I deal with customers every day as a home heat delivery driver, I would soon be out of a job if I treated my customers the way I have been treated by this company. Out of the 24 months I have had the bike over 7 of them have been spent in the shop or waiting to get there. I have posted a web page about these problems and would like for people to visit and leave a message for Suzuki or myself. It is you who can change the way these big companies look at us the consumer. I believe we as customers deserve better treatment than Suzuki Canada seems to want to give. Thank you. www.biketrouble.piczo.com.



Ken Vallis
Brownsdale, NL.

Last edited by Ken; 12-07-2005 at 10:49 AM.
Ken is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 12-06-2005, 09:34 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
That sucks man... but I'm sure it is one of those wierd random accurances...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #3 of 14 (permalink) Old 12-06-2005, 09:39 PM
 
Join Date: Sep 2004
Posts: 1,210


First you say ATV and then you say bike.....can you give the make and model of the machine you are speaking of?
Pippi is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 12-06-2005, 11:37 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
I seen that too...




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
post #5 of 14 (permalink) Old 12-07-2005, 01:37 AM
 
Join Date: Apr 2005
Posts: 461
I never had any probs out of my Suzuki
snakemann is offline  
post #6 of 14 (permalink) Old 12-07-2005, 08:22 AM
 
Join Date: Oct 2004
Posts: 6,147
Quote:
Originally Posted by snakemann
I never had any probs out of my Suzuki

Maybe...because...someone else is riding it??? You have a RR now...remember??
bumblebee is offline  
post #7 of 14 (permalink) Old 12-07-2005, 09:10 PM Thread Starter
Ken
 
Join Date: Dec 2005
Posts: 3
Hey Guy's, it's not the so much the quad I'm not happy with, it is the service
or lack of it that I have received from Suzuki. I hope nobody else has to go through what I have been through with this company.


Ken
Ken is offline  
post #8 of 14 (permalink) Old 12-07-2005, 09:16 PM
TWF Board Of Directors

 
Trip's Avatar
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 11,484
Send a message via AIM to Trip
I love my suzuki and the dealership was great about doing my 600 mile service. I have nothing bad to say about them at all. There are always exceptions, maybe it is just the people you are dealing with, you may want to try to find another dealership to work with.

2005 Honda CRF88RR - 2007 Honda CBR600RR
Trip is offline  
post #9 of 14 (permalink) Old 12-08-2005, 02:36 AM
Moderator
Lifetime Gold Supporting Member
'07 Rally Veteran
 
jeeps84's Avatar
 
Join Date: Oct 2004
Location: Western N.C. (The Great Smoky Mountains)
Posts: 20,168
Send a message via MSN to jeeps84
Quote:
Originally Posted by Pippi


First you say ATV and then you say bike.....can you give the make and model of the machine you are speaking of?
For those that missed it.
Quote:
Originally Posted by Ken
Suzuki LT-F400FK3 Eiger ATV


Ken

Submit your ride for the TWF Bike of the Month here


Currently ride 1987 GSXR 50, 1996 Ducati M900, 2005 GSXR 1000
jeeps84 is offline  
post #10 of 14 (permalink) Old 12-08-2005, 02:40 AM
Moderator
Lifetime Gold Supporting Member
'07 Rally Veteran
 
jeeps84's Avatar
 
Join Date: Oct 2004
Location: Western N.C. (The Great Smoky Mountains)
Posts: 20,168
Send a message via MSN to jeeps84
On the rare occasion that one of my Suzuki's have needed warranty/dealer work. I've always had a decent job in a timely manner.

Ken
I think your biggest problem is with the dealer. Not Suzuki in general.

Submit your ride for the TWF Bike of the Month here


Currently ride 1987 GSXR 50, 1996 Ducati M900, 2005 GSXR 1000
jeeps84 is offline  
post #11 of 14 (permalink) Old 12-08-2005, 07:54 AM Thread Starter
Ken
 
Join Date: Dec 2005
Posts: 3
Glad to see that this is not a problem that has happened to many Suzuki owners
but I haven't had much success with dealing with Suzuki Canada in Ont.I am not
the type of person to be posting letters against any company but this has been a
major headache for me for the last two years. I have the quad back now and maybe this time it has been repaired. Thanks for all your comments

Ken. Vallis
Ken is offline  
post #12 of 14 (permalink) Old 12-08-2005, 10:38 AM
 
Join Date: Sep 2004
Posts: 1,210
Quote:
Originally Posted by jeeps84
For those that missed it.

It wasnt in the original post - he just edited & added that in!
Pippi is offline  
post #13 of 14 (permalink) Old 12-08-2005, 10:40 AM
Moderator
Lifetime Gold Supporting Member
'07 Rally Veteran
 
jeeps84's Avatar
 
Join Date: Oct 2004
Location: Western N.C. (The Great Smoky Mountains)
Posts: 20,168
Send a message via MSN to jeeps84
Quote:
Originally Posted by Pippi
It wasnt in the original post - he just edited & added that in!
It is kind'of a long read. I almost missed it after the edit.

Submit your ride for the TWF Bike of the Month here


Currently ride 1987 GSXR 50, 1996 Ducati M900, 2005 GSXR 1000
jeeps84 is offline  
post #14 of 14 (permalink) Old 12-10-2005, 03:12 PM
V-Twin Moddin
 
Gas Man's Avatar
 
Join Date: Jul 2004
Location: SE Michigan
Posts: 38,916
Quote:
Originally Posted by Pippi
It wasnt in the original post - he just edited & added that in!
Yep... edited after Pips question...

But anyway, I think Jeeps is right... it is a crappy dealer giving Suzuki a bad rep! Just like with Twisty's bike losing his bar end after just a few weeks of riding... stupid dealer workmenship!




-Chris
aka Gas Man



Was: 2002 Kaw ZX-9R
IS:


is me till the
Gas Man is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome