Installed my fender eliminator last night on the SV...FINALLY - TwoWheelForum: Motorcycle and Sportbike forums
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-26-2006, 11:47 AM Thread Starter
First 1000 Member
 
Guideon72's Avatar
 
Join Date: Mar 2005
Location: Renton, WA
Posts: 543
Send a message via MSN to Guideon72
Installed my fender eliminator last night on the SV...FINALLY

Well, it's about a year later and I finally got to sit down for some quality time with my bike last night. I took everything off the back and finally figured out how to remove that pesky snowshovel rear so I could install my eliminator kit from Targa. Overall, I'm pretty impressed with the kit. It has a nice filler panel and came with some new blinkers that are WAY, WAY brighter than the stock ones. Being a real newbie to taking things apart the whole process took me about an hour or so, plus time for fixing user error (wired license plate to right turn indicator and vice versa ).

Before:



After:



I'm expecting some new flushmount front signals to be here in a week or so (Thanks for the headsup on those, Vol!) and then my lights will be all squared away.


-G

“Jeezus Snyder...You've always had more horsepower than sense!" -Joe M.
Guideon72 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-26-2006, 11:48 AM
 
Join Date: Feb 2005
Posts: 17,886
DLIT is offline  
post #3 of 6 (permalink) Old 07-26-2006, 11:49 AM
TWF Board Of Directors

 
Trip's Avatar
 
Join Date: Oct 2005
Location: Knoxville, TN
Posts: 11,484
Send a message via AIM to Trip
looks good, i want my flushies bad.

2005 Honda CRF88RR - 2007 Honda CBR600RR
Trip is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 07-26-2006, 12:25 PM Thread Starter
First 1000 Member
 
Guideon72's Avatar
 
Join Date: Mar 2005
Location: Renton, WA
Posts: 543
Send a message via MSN to Guideon72
Your connection must be blocked somehow, DL I don't know what to tell ya


-G

“Jeezus Snyder...You've always had more horsepower than sense!" -Joe M.
Guideon72 is offline  
post #5 of 6 (permalink) Old 07-26-2006, 12:27 PM
 
Join Date: Jul 2005
Posts: 24,016
Much much better.



marko138 is offline  
post #6 of 6 (permalink) Old 07-26-2006, 12:34 PM
 
Join Date: Feb 2005
Posts: 17,886
Quote:
Originally Posted by Guideon72
Your connection must be blocked somehow, DL I don't know what to tell ya
It's all good. I'll view it from home.
DLIT is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TwoWheelForum: Motorcycle and Sportbike forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome