Two Wheel Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi!

Few days ago I changed my exhaust on my kawasaki Z750 (2004). I removed my old original pipe and screwed a new one, which is totaly opened. It is an almost exact replica of akrapovic, maybe you heard of it form superbike or motogp, but is 40% cheaper. When I done that, I find that machine is not working “properly”. It’s not nothing serious but there is a difference in sound and work of the machine. The problem: the machine has a strange mumbleing sound between 1000-3000rpm. I heard that the problem is in somekind of vacum switch and some ruber hose somewhere around airbox, which are here because of the catalizator in exhaust. And because I removed catalzyed exahust pipe, the machine is not working properly at low revs.
Does anybody know exactly what has to be done so the bike should work properly again.

Greetings from Croatia (central Europe)
 

·
Registered
Joined
·
2,010 Posts
ok if im right and got my shiot striaght, kawi only did some stupids stuff with the exhaust in 2005 where if u put an aftermarket exhaust on the Fuel injection light comes on. but i know my 04 636 has a KLEEN Air system that is a little funky. basically if yours has it which im sure it does, there are 2 pair valves that route exhaust or air or somethign back int ot eh exhaust, i dont really understnad it but it can be routed to go to ur crank case. but this only stops the exhaust from backfireing and crackin like a mother f'er. but if it does have that stupid thing that they put on the 05 636 then what is happening is most of the exhaust comapnies are coming out with a fix for it.

BTW what kind of strange mumbling sound. with an aftermarket exhaust the bike willsound really different when idling than stock. its almost like a rumble idle.
 
1 - 2 of 2 Posts
Top