Two Wheel Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
My 2003 firebolt doesnt want to start, can anyone help me?
it sounds like it wants to start but it dont. :nonod:
 

·
First 1000 Member, March 2008 BOTM Winner!
Joined
·
4,183 Posts
Hmmm... has it been put up all winter? Did you add stabilizer to the fuel? Is it carbs or FI? Check the plugs?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Its FI, umm i got it at an auction so i dont know when the last time it was driven. I started it once yesterday, then couldnt start it after. No fuel stabilizer.
 

·
Banned
Joined
·
3,078 Posts
2003 shouldent have problems starting????
 

·
First 1000 Member, March 2008 BOTM Winner!
Joined
·
4,183 Posts
Might want to pull out the plugs and see how they look. If they are all black and grimy, or burnt and toasty lookin buy some new ones and toss em in.
 

·
First 1000 Member, March 2008 BOTM Winner!
Joined
·
4,183 Posts
Oh, and because you just got it, does it have any sort of fuel shutoff or a reserve on the gas tank or something? Did you try adding some new fresh gas?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
I was looking for fuel shut off but i did'nt find one. Putting new gas is a good idea. How can i drain it
 

·
Banned
Joined
·
3,078 Posts
sway818 said:
I was looking for fuel shut off but i did'nt find one. Putting new gas is a good idea. How can i drain it
just tip the bike over and let the gas run out.....naw but there should be a fuel line from the gas tank to the engine and you can unplug it let the gas run out
 

·
V-Twin Moddin
Joined
·
38,916 Posts
That was funny bull :lol:

Also, check the battery!
 

·
Registered
Joined
·
7,333 Posts
bulldog said:
just tip the bike over and let the gas run out.....naw but there should be a fuel line from the gas tank to the engine and you can unplug it let the gas run out

Looks like someone has been hanging with Gas MAn to much. Put the fumes down. :lol:
 

·
Moderator , Lifetime Gold Supporting Member, '07 R
Joined
·
20,168 Posts
Is the key on?
Is the kill switch in the ON position?
Is the kick stand up?
Is it in neutral?
Is it flooded?
Are the plugs fouled?
Does the battery have over 12.5 volts?
It takes allot of voltage to start a Twin!
 

·
Registered
Joined
·
4,335 Posts
jeeps84 said:
Is it in natural?
Huh? :lol: I know what you meant, but just had to give you crap.


As for the starting problem:
Did you ride it after starting it yesterday? If not, it could very well be the battery. You may have drained it below starting voltage with that last start, and then not charged the battery back up if you didn't actually go for a ride.
 

·
Moderator , Lifetime Gold Supporting Member, '07 R
Joined
·
20,168 Posts
Captain Morgan said:
Huh? :lol: I know what you meant, but just had to give you crap.


As for the starting problem:
Did you ride it after starting it yesterday? If not, it could very well be the battery. You may have drained it below starting voltage with that last start, and then not charged the battery back up if you didn't actually go for a ride.
Thanks Capt, I didn't even check. :crazy: FIXED I think! :bonk:
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #15 ·
I just got a new battery today it still did'nt start, the firebolts dont have a choke. strange situation, i heard a lot of things go wrong with buells.
 

·
Moderator , Lifetime Gold Supporting Member, '07 R
Joined
·
20,168 Posts
sway818 said:
I just got a new battery today it still did'nt start, the firebolts dont have a choke. strange situation, i heard a lot of things go wrong with buells.
It is a Harley motor! :lol: :wink:
There not that bad, just check all the thing above.
Also check that you are getting fir to the plugs. Might be a bad switch or coil pack.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #17 ·
yeah gonna take it in to service tommorow, hope they dont try to rip me off.
i heard it yesterdayt and it sound sweet.
 

·
Moderator , Lifetime Gold Supporting Member, '07 R
Joined
·
20,168 Posts
sway818 said:
yeah gonna take it in to service tommorow, hope they dont try to rip me off.
i heard it yesterdayt and it sound sweet.
Yea, I like the Buell's also. :dthumb:
Just waiting on the V Rod motor to be shoe horned in! :lol:
My Monster is getting well out dated. :whistle:
 

·
Registered
Joined
·
21 Posts
Hey Sway, XB's have fuel injection with out a choke. Pull a plug wire off and see if you are getting spark. If you are getting spark then pull the plugs. The back plug is a pain in the A-- to get to. Buy a service manual and a parts manual. The parts manual is great because it has exploded views of the bike. It may be bad fuel in the tank. If so I looked in parts manual and the Fuel pump is located at the back of the frame somewhere near where the swing arm is located. You should be able to locate a inline fuel filter to drain the bad fuel out. If you don't want to do that then take it to a dealer that carries Buell motorcycles to check it out. Sorry if I wasn't more help then that. Brupska
 

·
Moderator , Lifetime Gold Supporting Member, '07 R
Joined
·
20,168 Posts
Yea, what he said!
My local Harley shop will work on Buell's but, they rip hard. I was told they wouldn't even look at one if not for some sort of agreement between Buell and Harley. :screwy:
 
1 - 20 of 24 Posts
Top