Two Wheel Forums banner
1 - 20 of 68 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I bought a 94 gsxr750 a couple of weeks ago I have noticed that the turn signals do not work properly otherwise they do not flash when you turn the turn signal on they are solid there is no flashing. I did put new turn signals on the bike because they did not have any to begin with. I followed the wiring diagram so I know that these are the correct wires left side black(positive) Black w/ white tracer (neg) Right side Light green (positve) Black w/ white tracer (neg). I did put a new turn signal relay in I thought it was the problem.
I hope someone can help me out. Thanks flipmo
 

·
Registered
Joined
·
7,333 Posts
First welcome to TWF. Second, you came to the right place looking for answers.

Now you say it didn't have turn signals? Was the bike set up for the track? Did You have to run the whole wiring?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
No it was not set up for the track the guy that I bought it from just didn't put the turn signal back on after he painted the bike and the wires were cut and right were they should be leftside rightside and rear they just don't flash.
 

·
Registered
Joined
·
7,333 Posts
Test the wires to see if your getting any juice through them.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #6 · (Edited)
I did check the fuse and its ok but I did replace it any way I am getting juice through the wires. It sucks I just can't figure it out.
 

·
Registered
Joined
·
7,333 Posts
zx636r said:
try switching positives with neg. see if it works. maybe you switch is bad.

Good call. :dthumb:
 

·
Moderator , Lifetime Gold Supporting Member, '07 R
Joined
·
20,168 Posts
Don't be mad but, did you check the bulbs? That's the way it acts when you have a blown bulb on one end!
If the bulb is good check the socket its self. Ground on the rime and hot on the pin in the middle.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #11 ·
the bulbs work because they come on they just don't flash I put new lockhart phillips turn signals on the rear and flush mounts in the front.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #13 ·
I dont think so The rear are short stem turn signals and the front and flush mount turn signal light why do you ask?
 

·
Registered
Joined
·
2,010 Posts
cause if they are led they can possible just stay on steady when you turn on the signal and not blink at all. if they are led they will have led lights and yo will be able to tell, they will ahve multiple bulbs in them.
with led lights you need resistors or they blink too fast or just stay on period.
 

·
Registered
Joined
·
2,010 Posts
ah ha this will hopefully be and easy problem fix. your risistor is screwed. signals have a thingy that gets hot and breaks liek a fuse almost and then goes back and then breaks, thats where you get ur blinking from. i would just buy risistor and put them on, you can get them for liek 10-20 bucks, this should solve you problem.
 
1 - 20 of 68 Posts
Top